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List of Abbreviations 

Abbreviation Meaning 

3G/4G Mobile phone network technology – third and fourth generation 

AVI A file extension for a multimedia video format file 

BMP Bitmap image file 

CAN Controller Area Network 

CPU Central Processing Unit (computer resource) 

CD Compact Disc 

DTC Diagnostic Trouble Code 

DVR Digital Video Recorder 

DVD Digital Video Disc 

EDGE Enhanced Data rates for GSM Evolution (type of router) 

FMS Fleet Management System 

FTP File Transfer Protocol 

FX Effects 

GB Gigabytes 

GSM Global system (or standard) for mobile 

GPRS General Packet Radio Service 

GPS Global positioning System 

HTML Hypertext mark-up language, system for tagging text files to show colour etc 

IP Internet Protocol 

IPS Images per second 

JPEG A format for compressing image files 

KPH Kilometres Per Hour 

LAN Local Area Network 

MB Megabyte 

MKV Matroska video file, a popular file format for High Definition video 

MP4 A digital multimedia format commonly used to store video and audio. 
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MPG An international standard for encoding and compressing video images 

MPH Miles Per Hour 

NAT Network Address Translation 

NTSC The television broadcasting system used in North America and Japan 

NVR Network Video Recorder 

OBA File type unique to the Timespace X100 digital video recorder 

OSM The Open Street Map website 

PAL Phase Alternating Line 

PC Personal Computer 

PGN Parameter Group Number (in vehicle CAN data) 

PTZ Pan Tilt Zoom (camera) 

RAM Random Access Memory 

RMC Recommended Minimum data in GPS containing position, course & speed 

SIM Subscriber identity module 

TCP Transmission Control Protocol 

TFTP Trivial File Transfer Protocol 

UDP User Datagram Protocol 

UMTS Universal Mobile Telecommunications Service 

USB Universal Series Bus (cable system) 

V Volts 

VLC Video LAN Client 

VPN Virtual Private Network 

XBA File type unique to Timespace digital video recorders 
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1 About This Manual  

This manual contains the information required for the installation and use of Timespace Technology’s 

PCLink Suite software. 

PCLink Suite comprises a number of programmes: 

 PCLink200 

 PCPlayer 

 RemoteLink 

 XCommunicate 

This manual is divided into the following sections: 

 Introduction to PCLink suite 

 PCLink200 Quick Reference Guide 

 PCLink 200 User Interface in Detail 

 PCLink200 Features and Functions 

 File Transfer 

 Software Updates and News. 

 Appendix – Manual Revision History 

 

Within the User Interface section of the Manual, links to other more detailed sections are given as 

hyperlinks.
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2 Introduction 

2.1 PCLink Suite 

Timespace PCLink Suite consists of applications that allow Playback, Live View, Configuration and 

Download/export of recorded files from all Timespace digital video recorders (DVRs). 

PCLink200 is a Windows based application that allows .xba files to be viewed on a PC. XBA files are 

created by Timespace DVRs on either an internal storage device or a removable disk cartridge. For X 

& V-series DVRs the cartridge can be connected to the PC via a USB cable to access the files. For K-

series DVRs the DVR itself is connected to a PC via USB. 

Playback options for video and audio include play, forward-wind, rewind, jog control, jump to 

markers, time line jumping and stop. 

Video can be exported from Timespace XBA format to various standard video file formats (MP4, 

MKV, MPG and AVI). Camera images can be saved as still pictures to the Windows clipboard or saved 

directly to a JPG/BMP file. 

PCLink's integrated mapping displays the location and real-time movement of a Timespace DVR when 

using a GPS aerial (added separately to a Timespace DVR). 

PCLink also provides export of GPS mapping and speed data, GSensor data from the DVR’s built-in 

accelerometer, and motion data from Timespace DVRs which have motion-detection functionality. 

2.2 Software Requirements 

PCLink200 runs on the following Microsoft Windows operating systems (32/64Bit): 

 Windows 10 onwards 

 Windows server platforms 2012 R2 onwards 

Older operating systems are supported at the time of issue of this manual, but may be dropped in 

the future.   

From PCLink V8.4.2 onwards, some features available in the 64-bit builds will not be available in the 

32-bit builds.  Please contact Timespace for further details.  

PCLink runs using an elevated Windows permission state i.e. highest available however it does 

require Administrator Rights to run correctly with all features. This is because PCLink has the ability 

to write to the local PC hard drive for example when saving screenshots or exporting video files. Also 

PCLink has the ability to open network sockets on the PC to communicate with Timespace DVRs for 

example to view Live video remotely or download video files. Included with PCLink Suite is a 

standalone PCPlayer that can be run without installing and does not require Administrator Rights. 

PCPlayer does not include all the features that PCLink does. 
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2.3 Hardware Requirements 

Operating System 64bit Windows 10 or later 

Older systems are currently supported, but may 
be dropped in the future. 

CPU 2.5 Ghz, Intel i7 6 core (avoid i3s) 

Memory 16GB 

Disk Space System: 500GB SSD  

Network Gigabit LAN 

 

Playing footage from DVRs at 200IPS or with IP camera footage can be very demanding.  Therefore 

we recommend using a PC with a multi-core 11th generation (or greater) Intel Core processor and a 

dedicated graphics card. 

Some on-board graphics cards may need windows ‘hardware acceleration’ turning down for 

optimum playback speed. 

PCLink will run on older, slower machines, but playback may pause, and sound become “choppy”. 

2.4 Installation 

In most cases the installation program will run automatically. If this does not happen use Windows 

explorer to select the CD ROM drive and the installer will start. Installation may take several minutes 

if an update to .NET is required. 

To start running PCLink200 click the Windows Start > Programs > PCLink Suite > PCLink shortcut. 

2.5 License 

The purchase of a Timespace USB interface kit or cartridge station includes the necessary licence for 

use of PCLink Suite software including free of charge updates on a single PC (reasonable use policy 

allows installation on a secondary portable PC; laptop).  Timespace Technology does not authorise 

the unlicensed usage of PCLink Suite software. 



PCLink Suite 8.4.4 Instruction Manual                                                                                                    Section 3 – PCLink Suite Quick Reference Guide 

4 

 

3 PCLink200 Quick Reference Guide 
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3.1 Camera Zooming  

 

 Multiple cameras can be zoomed at different levels during playback by using the mouse scroll wheel. 

Once zoomed in, the image can be panned by clicking & dragging. 

3.2 Keyboard Shortcuts 

Key(s) Operation  Key(s) Operation 

Space Bar Play / Stop  Keypad + Increase playback speed 

; FFWD  Keypad - Decrease playback speed 

H REWIND  [ Set left marker 

J JOG Backwards  ] Set right marker 

L JOG Forwards  I Jump to start marker 

Ctrl + F Load folder  O Jump to end marker 

Ctrl + R Load remote unit  R Confine markers to displayed 

footage 

Ctrl +O Load XBA  Alt + Enter Displays properties window 

Ctrl +P Print Image  Scroll lock Export cameras to folder 

Ctrl +S Save file  F11 Full screen 

Ctrl + Shift + L Loop Playback (between 

markers) 

 Esc Exit full screen 

Ctrl+Left mouse click on any of the ALARM PANEL icons will jump to the next occurrence of that 

alarm in the timeline (if any). 

Ctrl + click on the camera number will show/hide that camera. 

3.3 Installing Cartridge 

To access recordings on the cartridge, connect to a PC using the USB Interface Kit from Timespace 

(cable or cartridge station).  

If using an X100/X200 cartridge, switch the cartridge power switch to the on position. 

Once the disk has been connected, the PC should take a few seconds to detect the disk and Windows 

should automatically assign a drive letter to it.  
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The drive should be viewable in Windows Explorer and .XBA files visible with their associated icon 

(assuming PCLink Suite is installed); 

 

 

Recording files can now be viewed using PCLink200 by either double clicking on an individual file 

from Windows Explorer or loading file(s) or cartridge from within the PCLink application. 

3.4 Removing Cartridge 

Cartridges should be safely removed from Windows operating system environment prior to removing 

power/USB cable. Data loss or corruption may occur if this is not followed. 

To safely remove the cartridge from a Windows PC; double click on the “Safely Remove Hardware” 

icon in your system tray, select the device (drive letter assigned) to be removed from service, select 

“Stop”, select “OK” then “Close”. Alternatively, single-click on the “Safely Remove Hardware” icon in 

your system tray and select the appropriate device from the pop-up dialogue. Wait for the drive 

activity light to stabilize. Power-off and/or disconnect the drive. 

NB: For X200, cartridges > 160GB must be used with the T505 USB cable. 

3.5 Loading .xba files  

There are several ways to view XBA files in PCLink200; 

 

1. Individual files can be opened directly from Windows Explorer by double clicking. 

2. Group selected files can be dragged from a Windows Explorer window and dropped onto the 

main area of the PCLink200 window. 

3. Up to 15 files can be opened by selecting them and using RIGHT CLICK > OPEN WITH 

PCLINK200.  

4. The entire cartridge can be loaded by opening PCLink200 and selecting the AUTOLOAD 

option. 

5. A specific folder can be loaded from within PCLink200; FILE menu, LOAD FOLDER. 

6. A specific file can be loaded from within PCLink200; FILE menu, LOAD FILE. 

7. Files can be loaded from a remote DVR using an IP connection; FILE, LOAD REMOTE UNIT. 
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4 PC Link200 User Interface In Detail 

4.1 Play Controls and Timeline 

Once an XBA file is loaded (see section on loading files), PCLink can be used to play and review the 

footage on the file.   

The play controls and timeline are at the bottom of the PCLink screen. 

 

 

4.1.1 Play Controls 

Control Function 
Keyboard 
shortcut 

Play Click once to play footage.  If clicked whilst footage is playing the 

play button will stop the footage.  

space bar 

Stop Click once to stop the footage at any time.  space bar 

Rewind Click once to rewind the footage by a few seconds whilst playing 

or stopped.  Hold down to fast rewind the footage. The size and 

speed of this rewind is relative to the amount you are zoomed in.  

H. 

Jog back Click once to rewind the footage by 1 second (to the nearest 

available keyframe) whilst playing or stopped 

J. 

Jog 

forwards 

Click once to advance the footage by 2 images whilst stopped L. 

Fast 

forward 

Click once to advance the footage whilst stopped.  Hold down to 

fast forward the footage whilst playing or stopped.  

; 
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4.1.2 Date/Time display  

Time and Date - The current time and date of the footage shown on the screen is displayed directly 

above the play controls. 

Double click on the date/time strip to open a Search dialog box.  Right-click to copy the current 

playback date/time to the clipboard in the format "%H:%M:%S %d/%m/%y". 

4.1.3 Playback Speed 

Playback speed selector allows the footage to be played back from between 0.1 and 10 times its 

normal playback speed.  

NB: playback speeds x4 or higher are generally reserved for lower IPS recordings due to the host PC 

processing capability. Max speed plays video back as fast as possible.  

4.1.4 Volume control 

Slide to the right and left to increase and decrease playback volume respectively.   

NB: When audio is disabled in the Audio Menu on the DVR, the volume control in PCLink will appear 

with a red line through it.  

4.1.5 Timeline and section markers 

The timeline can be used to select and view the footage at a particular point in time. Click once on 

this bar and the footage will jump to this time. The playback position indicator can also be dragged 

by holding down the left mouse button.  

The two yellow triangles at the beginning and end of the timeline are the section start and end 

markers. By default these will appear at the start and end of the available footage when it is loaded, 

but they can be dragged by holding down the left mouse button to other points of the footage if 

desired. This is useful when using the Export video option or the Loop footage feature to repeatedly 

play a section of footage. 

The timeline scale can be selected to cover from 15 minutes to 1 year; the ‘Fit’ option scales the 

timeline to cover all of the currently loaded footage from beginning to end. 

 

GREEN areas on the timeline indicate normal recordings. 

RED areas indicate an ALARM event, if configured within the DVR. 

BLUE indicates that the footage has been opened remotely over an IP connection. 
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4.1.6 Motion Graph 

NB:  The motion graph/tab will only be displayed for DVR products which support this feature and is 

shown per camera.  The X200, X300 and X500 DVRs have motion detection.  V-series DVRs do not. 

The motion graph bar is shown below the timeline and indicates the relative level of motion (change) 

in the recording. The level of motion is indicated by the height and intensity of colour of the bar, 

higher and darker indicates higher motion and lower and lighter indicates lower motion. 

The motion graph bar will show the level of motion for the currently highlighted camera. If a number 

of cameras are highlighted then the graph will display the data for the camera which has the highest 

level of motion and not the average level across all cameras. If no cameras are highlighted then the 

graph will display the data for the camera which has the highest level of motion from all of the 

recorded cameras. 
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4.1.7 GSensor / Speed Graphs 

Timespace DVRs can record the G-Force movement and speed and playback in line with the video 

footage. All readings are displayed together but one reading will be more prominent depending on 

which tab is selected. Each reading is colour coded along with a key in the bottom right hand corner. 

The Speed tab displays only the speed reading. 

 

 

HINT: use the expand button or click and drag the Timeline area to grow the graphs. 

 

 

 

 

 

 

 

 

 

Motion graph status text – hovering the cursor over the graph display will reveal status text which 

lists the readings and the time the readings were taken.  The status text is in the right-hand corner of 

the motion graph area, as shown below.   The two small squares show the reading times.  This is 

useful when zoomed in, ie to see how frequently GPS is being read.  

  

Motion status text 
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4.2 Menus 

4.2.1 File  Menu 

File > Load File – Opens a single .xba file from a user specified location.  Select the file and press 

open. If an .oba (X100) file is selected then PCLink100 will automatically start in a new window and 

the file can be opened from there. 

File > Load Folder – Opens a group of .xba files from a user specified folder. Select the file and press 

open. This can also be used to load all the files from a cartridge connected to the PC. To do this select 

the drive letter in My Computer assigned to the cartridge and press open. All of the available footage 

from the cartridge will then be loaded. 

 

 

 

If a folder containing both .xba  and .oba files is selected then PCLink200 will ask which type of files 

are to be viewed. If XBA is selected then PCLink200 will load all of the available .xba files.  IF OBA is 

selected then PCLink100 will automatically start in a new window and the .oba files can be opened 

from there. If a folder containing only .oba (X100) files is selected then PCLink100 will automatically 

start in a new window and the files can be opened from there. 

File > Load Remote Unit – Opens a window which allows a remote connection to a Timespace DVR 

over an IP network to view live cameras, playback recorded footage, download footage and 

configure the DVR. 

To access the DVR add the remote unit to the list by entering a name for the unit and its unique IP 

address (note that all Timespace DVRs have the default IP address of 10.0.0.200). The IP address 

must be unique and once the details have been entered click the ‘Add’ button to add the unit to the 

remote unit list. To delete a unit already on the list select it by clicking on the unit name and then 

click ‘Delete’. 

The ‘Load List’ feature allows the user to load the unit name and IP address for multiple units 

managed by a Timespace LANLink system, XML file format, contact Timespace support for details. 

  

NB:   files (and files in folders) may be password-protected or encrypted.  For further details on 

opening this type of file, please see File Password and Encryption Settings. 
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Units which show  next to them can be connected to. 

Units which show  cannot be contacted and should be investigated at a network connectivity 

level; investigate DVR configuration, firewall/security product restrictions installed on the PC and any 

network security devices.  

NB - See REMOTE ACCESS:  Load Remote Unit page for more detailed options. In particular see the 

Adaptor IP setting in the advanced Edit dialog for a unit. 

File > Close Files – Closes currently opened .xba files.  

File > Print – Prints the currently selected camera view. 

File > Copy Image – Copies the currently selected camera view to the clipboard in Windows Bitmap 

format. 

File > Export Video Four sub menus exist for Exporting; 

> Create XBA DVD - Burn a DVD with XBA files and PCPlayer. 

> Export XBA File - Exports the section of footage between the start and end markers as an 

XBA file.  A dialogue box will appear allowing the user to select which cameras, audio 

channels and data (GPS and motion) is included in the exported XBA.  

> Create Video DVD - Convert XBA to a DVD format and Burn a DVD (can be played in a 

standard DVD player e.g. in a courtroom). 

> Export Video Grid - export a single-stream MP4 file which contains multiple cameras 

arranged in a grade (similar to the DVD export option) 

> Export Video File - Export an XBA file to another format e.g. AVI, MPEG2, MPEG4. 

A section of footage between the start and end markers can be exported.  Selecting one of the above 

export methods will load a dialogue box allowing the user to select further options such as codec, 

start/end times, include audio etc.  

 

 

 

The maximum file size can be limited in order to fit the resultant parts to certain media e.g. CD/DVD.  

In this case if the total size of the exported footage exceeds the maximum file size selected then a 

number of files will be created all with the same name as entered in the ‘File Name’ box, but having a 

suffix to the file name -part2, -part3 etc. The user can select one of the standard maximum file size 

limits or alternatively select ‘Custom’ from the drop down menu.  If custom is selected then the user 

inputs the required maximum file size in the ‘Mb’ window next to the drop down menu. 

NB:   reference the Exporting section of this manual for further information.  See File Password 

and Encryption Settings for details on password-protecting and/or encrypting files for export. 
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File > Export Image – Exports the currently selected camera view as a Windows Bitmap or JPEG to a 

location specified by the user. JPEG produces file sizes approximately 20 times smaller than bitmap 

with no discernible loss in image quality. 

File > Export Audio - Exports the section of footage between the start and end markers as a WAV or 

MP3 file.  Choose the output file name/destination and the period of footage required.  

File > Export Cameras to Folder – At any time during play back it is possible to save all of the current 

camera views to a folder as separate JPEGs (one for each camera view) by pressing the Print Screen 

key on the PC keyboard.  

There is an option to export only 1 camera by holding down the <CTRL> key while selecting ‘Export 

Cameras to Folder’. The exported camera will be the first selected camera, or if no cameras are 

selected, the camera with the lowest number that is displayed.  

The JPEGs will be saved to a folder as specified in the preferences dialog.  The Preferences dialog is 

accessed by going to Options > Preferences.   

NB if the user does not specify a location for the exported images, then by default the images will be 

stored in the same place as the original XBA file was loaded from.  This may cause problems if the 

XBA file was loaded directly from a Hard Disk Cartridge which may have limited free space available. 

The format for the file names is of the form: 

19th Nov 2010 14.10:00 [cam 01] .jpg 

19th Nov 2010 14:10:00 [cam 02] .jpg 

If multiple images exist for the same time (when using a record rate over 1IPS per camera) then 

PCLink200 will not overwrite previously exported images but will instead append the file names with 

a bracketed number so that the correct sequence of images can be determined. For example: 

19th Nov 2010 14:10:00 [cam 01] (1) .jpg 

19th Nov 2010 14:10:00 [cam 01] (2) .jpg 

 

File > Check Watermarks –  

> Create Report for Loaded Files – This feature checks the watermark for every image in the 

footage between the start and end timeline markers (these are set at the beginning and end 

of all the currently loaded footage by default).  

> Create Report for Cartridge/Folder does the same as check loaded files, but on a cartridge 

or a folder containing XBA files. 
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When the check is complete an HTML log file is produced and automatically opened. This log file lists 

all of the checked files and has a summary section at the bottom. Each file has a ‘+’ symbol next to it 

for further information about that file. This extra information will automatically be shown if there 

were problems with the watermark for this file. Information includes; Unit serial numbers, start/stop 

times, sequence numbers and also a file CRC and SHA1 checksums (which are also written to a 

separate file, with a link added to the html report). 

File checks are categorised into three states: 

Passed check (green) 

Passed check with issues (blue) 

Failed check (red) 

Files pass with issues if: 

File was not closed properly (power off during record) 

File was not closed properly (power off during record) and the last video/audio frame failed 

the watermark check 

Files are missing their sequence frame (in newly generated files) in non-properly closed files 

(power off during recording) 

Files fail if: 

Any video/audio frame (other than the last in a non-closed file) had an invalid watermark  

Video frames were missing or out of sequence (in newly generated files) 

Files passed to the checker were not in sequence (in newly generated files) 

Files are missing their sequence frame (in newly generated files) in properly closed files. 

 

File > Load Blur –  loads previously saved blur file 

Recent Files – Displays a drop-down list of recently opened .xba files, click on an item to load the file.  

Please note that this will not work if the file has been moved since it was last opened. 

File > Properties – Brings up a summary of the current .xba file properties such as start/end times 

and file size. If connected remotely, pressing the Open Folder button will launch an FTP browser link 

to enable file downloads.  NB:  the file properties dialog can be enlarged to show all the details, eg 

file security settings, file size etc.  

File > Exit – Exits the PCLink200 program. 
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4.2.1.1 Export data (GPS speed, GSensor and Motion) 

GPS mapping data can be exported in PCLink as a .gpx file, see dropdown below.  From PCLink 8.4.4 

onwards, PCLink also provides for export of raw GPS Speed, GSensor and Motion Data from the XBA 

files.  The data is exported as a spreadsheet in .CSV format.   

In File > Export  Video >Export XBA File there are 3 new entries in the “Save as type” dropdown: 

 GPS Speed Data files 

 GSensor Data Files  

 Motion Data Files   

Motion data will only be available for Timespace X200 and X300 DVRs.  Each line has a time and a 

value for all 16 possible cameras. 

For footage from X200 DVRs, no GPS or GSensor data.  only the option for a Motion Data File will be 

shown –  

 

 

The three new CSV files will contain relevant information on the loaded files between the start/end 

time range. 

GPS Speed Data files contain the time, and a MPH (or KMH if set in Options > Preferences > Dials > 

Units) value derived from the GPS data: 

Time,MS,Speed (MPH) 

  17:30:00, 400, 14 

  17:30:01, 400, 15 

  17:30:02, 400, 17 

… 



PCLink Suite 8.4.4 Instruction Manual                                                                                                      Section 4 – PCLink200 User Interface in Detail 

16 

 

NB the OSD speed units can also be set on the DVR itself in the GPS settings page.  Therefore there 
may be occasions when the units (eg MPH/KMPH) showing on the video do not match those showing 
on the speed dials.  
 

G-Sensor Data files contain the time, and then values for all 3 axis: 

time,ms,lateral,forward,upward 

  17:30:00, 0, 0.02, 0.03, 0.00 

  17:30:00, 100, 0.02, 0.03, 0.00 

  17:30:00, 200, 0.01, 0.03, 0.00 

  17:30:00, 300, 0.02, 0.03, 0.00 

… 

NB: Technically the upward value should be -1 (due to gravity), but 1 is added to centre the graphs 

around 0. 

4.2.2 View Menu 

View > Bars  

Bars allows the user to toggle on/off the main PCLink toolbar, as well as the side information bars for 

FX / Blur / Bookmarks / CAN / FMS / G (G-Force) / GPS. 

 

 

 

 

From PCLink Version 8.3.0 onwards, individual side information bars can be detached, moved, 

resized, docked and undocked.    See Information Side Panels for more details.  

View > Cameras – This will display a drop-down list of cameras. Either check or un-check each 

camera to have it displayed or not displayed in the PCLink200 window.  Cameras with available 

footage will have their number displayed in black, all others will be displayed in grey and are not 

accessible.   

NB:   the default is to show the GPS bar when PCLink is started.  PCLink will reset the default to 

this every time a new version of PCLink is installed.  
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NB: The cameras listed cover all Timespace recording products, and therefore will not all be 

applicable to every DVR/piece of footage.  The cameras available for the currently shown footage will 

be shown across the top of the Toolbar.  

 

 

 

 

 

 

 

 

View > Show Selected Cameras – This will display all of the currently checked cameras in the Camera 

list. 

View > Show only 4 cameras – this option limits PCLink to displaying up to 4 cameras.  Cameras can 

be turned on and off on the toolbar.  This option is intended primarily for use with older PCs when 

requiring playback from the Timespace V700 DVR (full-HD DVR so recorded files are large). 

View > Show Selected Camera Larger Than Others – This will display the selected camera as a large 

image, with other camera tiles as smaller thumbnail images. 

View > Show All Cameras – This will display all cameras for which there is available footage. 

View > Undock Selected – Undocks the currently selected Camera/Map tile from the main PCLink 

Windows, allowing it to be moved/resized as required.  

View > Undock Map - Undocks the Map tile from the main PCLink Windows, allowing it to be 

moved/resized as required. 

View > Redock All – Redocks any undocked camera/map tiles. 

View > Deinterlace - This controls PCLink’s deinterlacing functionality for interlaced D1 footage 

recorded by an X300 connected to a multi-field camera.   NB only the X300 DVR supports interlaced 

video.  If ticked, PCLink will combine both the odd and even video fields and perform a deinterlacing 

algorithm to provide a higher resolution frame.  

If not ticked, PCLink will simply show the even field only resulting in a lower resolution frame. 

Deinterlacing can be quite demanding on the CPU. Turning it off will provide faster playback. 

View > Full Screen – This will display the selected camera window full screen without the PCLink200 

HINT:   Double clicking on any displayed camera window in a multiple camera view will display it 

full screen.  Left-clicking any part of the surrounding grey area will revert back to a multiple 

camera view.  

 Multiple camera views can be selected by holding down the Ctrl key whilst left clicking on the 

desired camera windows.   

If multiple camera windows are selected then double left clicking whilst holding down the Ctrl key 

will display only the selected cameras.  Left clicking any part of the grey area of the window will 

revert to all camera windows being displayed.  
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menu bar or playback controls.  Press Esc to return to normal viewing mode.  Full screen view can 

also be toggled by pressing the F11 key on the keyboard. 

View > Tool Bar – toggles on/off the PCLink tool bar at the top of the screen 

View > Status Bar – toggles on/off the status bar at the bottom of the screen.  Right-clicking on the 

status bar itself gives the option to turn on/off various pieces of information, eg PCLink date and 

version number, CPU load etc.  

4.2.3 Controls Menu 

Controls > Play / Stop – This will toggle the footage from playing to stopped and vice-versa. Also 

controlled directly by the Space Bar on the keyboard. 

Controls > Looped playback – Will continuously loop the footage between the start and end markers. 

Also directly controlled by using Ctrl + Shift + L. 

Skip Low Motion Playback - During playback will skip over any low motion footage +/- n seconds 

pre/post as configured in Options>Preferences.  This is very useful to reviewing footage and masking 

out areas with no activity. 

Controls > Jog Forwards – Causes the footage to jog forwards. Also controlled directly by the L key 

on the keyboard. 

Controls > Jog Backwards – Causes the footage to jog backwards. Also controlled directly by the J key 

on the keyboard. 

Controls > Jump to Start Marker – Causes the footage to jump to the start marker. Also directly 

controlled by the I key on the keyboard. 

Controls > Jump to End Marker – Causes the footage to jump to the end marker. Also directly 

controlled by the O key on the keyboard. 

Controls > Jump to – Brings up a dialogue box allowing the user to input a time and date to jump to. 

If no footage is present at the selected time and date then the nearest footage will be selected.   

Controls > Confine Markers to Displayed Footage – Sets the start and end markers to the beginning 

and end of the currently displayed Timeline. This is useful if only a portion of the total footage 

Timeline is currently being displayed. Also directly controlled by the R key on the keyboard. 

Controls > Set Left Marker To Play Position – Sets the left (start) marker to the current play position 

on the Timeline. Also directly controlled by the [ key on the keyboard. 

Controls > Set Right Marker To Play Position – Sets the right (end) marker to the current play 

position on the Timeline. Also directly controlled by the ] key on the keyboard. 
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4.2.4 Audio Menu 

Audio > Audio Enabled – Enables audio playback on both channels. 

Audio > Left Channel Only – Enables audio playback on the left channel (channel 1) only. 

Audio > Right Channel Only – Enables audio playback on the right channel (channel 2) only. 

Audio > Audio Disabled – Disables audio playback (Mute). 

 

Audio controls are also located in the Playback Controls section at the bottom of the screen: 

 

 

 

 

 

Clicking the loudspeaker icon completely turns off the audio sub-system in PCLink, whereas selecting 

Mute in the dropdown keeps the audio system active, but doesn’t queue any new audio. By keeping 

the audio system active, the switch to an audio stream is much smoother. 

4.2.4.1 X500 High Quality Audio 

PCLink from software version 8.0.2 onwards supports the High Quality Audio feature on the X500 

DVR. 

To select the audio stream playing back, a new drop-down has been added to the Playback Control 

bar. The selected text in the control shows the currently playing audio. You can change this by 

clicking it and selecting a different audio stream. 

 

 

The content of the dropdown changes depending on the current file.  
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The new X500 channels are referred to as HQ1, HQ2, HQ3 and HQ4.  

The “1+2” and “3+4” options allow the HQ channels to be played as a stereo pair. 

The “1-4” option allows all the HQ channels to be mixed into 1 mono channel. 

 

 

For non-X500 files, or X500 files which utilise the extra input channel we refer to the audio as the 

standard inputs. “L+R” here means play both channels as stereo audio.  

 

 

4.2.4.2 Camera-based Audio Selection 

A feature from PCLink 8.0.2 onwards is the ability to give a camera a preferred audio channel. When 

the camera is selected, PCLink will try and switch to this audio channel. 

This is currently set up in the Options > Camera Grid Setup. 

Further settings for HQ Audio can be found in the Options > Preferences > HQ Audio dialog. 

4.2.5 Options Menu 

Options > Cartridge Autoload – Check this option to autoload all footage from a Hard Disk Cartridge 

which is attached to the PC before or after PCLink200 is started.   

If a Cartridge containing both .xba (X200) and .oba (X100) files is connected then PCLink200 will ask 

which type of files are to be viewed.  If XBA is selected then PCLink200 will load all of the available 

XBA files.  IF OBA is selected then PCLink100 will automatically start in a new window and the OBA 

files can be opened from there. If a Cartridge containing only .oba (X100) files is connected then 

PCLink100 will automatically start in a new window and the files can be opened from there. 

  

NB:   The “Mute” option in the dropdown will be selected if there is no audio in the file.  

the default is to show the Blur bar when PCLink is started. 
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4.2.5.1 Passwords for use of PCLink 

Options > Passwords > Set PCLink Password – sets a password to prevent unauthorised use of 

PCLink software.   

Options > Passwords > Set Export Password – sets a password to prevent unauthorised export of 

files from PCLink. 

 

 

 

Options > Passwords > Enter Playback Password - If an XBA file has been recorded with a password, 

enter it in this menu in order to playback the file(s).  If a password hasn't been entered and PCLink 

detects a file that requires one, a popup will be presented to the user in order to enter a password. 

 

 

 

 

 

  

NB:   The default password is blank spaces.  Setting it back to this will remove any password 

protection. 
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4.2.5.2 Preferences 

Options > Preferences – This brings up a menu allowing the user to specify a number of display and 

export preferences. 
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Playback 

Display frame rate (and Video Channel Text) - This option displays the frame rate, camera type 

(PAL/720P/1080P) and audio rate (if audio is present) for each channel in the information bar 

underneath each video window. Default: disabled.  

 

When enabled, the IPS Video Rate will always be present (except in live), other details will be added 

in the following order if screen space is available (depending on Window size): 

1. Video Rate (non-live playback only) eg 4IPS, 10IPS etc. 

2. Audio Rate (non-remote playback, and only if audio exists): eg: 

", 44.1kHz (l)" 
", 44.1kHz (r)" 
", 44.1kHz (lr)" (lr for stereo) 
 

3. Frame Size: eg PAL; or for AHD cameras (1280 x 720) or (1280 x 1080P); or for IP cameras the 

relevant size. 

4. Video Quality (if known): 

" (Super Q)" 
" (VVHigh Q)" 
" (VHigh Q)" 
" (High Q)" 
" (Medium Q)" 
" (Low Q)" 
 

5. Finally, one or none of: 

" [Live]"    (liveview mode) 
" [Remote]"  (remote file playback) 
" [X300]"    (local x300 playback) 
" [h264]"    (local h264 format playback.  Letters U, M or F may also be shown to indicate which 
decoder is in use.) 
 

Maintain Video Aspect Ratio – When enabled, PCLink will keep the video source aspect ratio. When 

disabled, all camera tiles will be sized the same.  This option will be particularly used when playing 

back a mixture of analogue and IP cameras. 
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Deinterlace D1 footage (X300) – When enabled, PCLink combines the two fields of interlaced 

footage into a single higher-resolution frame. When disabled, PCLink only displays the first field of 

interlaced footage. On a less powerful PC, playback will be much quicker with this option disabled. 

The X300 is currently the only recorder which supports multi-field recording (D1 Resolution). 

Keep playing on seek - If the user drags the play head cursor or clicks in the timeline window during 

video playback, the system will seek to the new time thus selected. This option determines how the 

system behaves after this seek. If enabled, the playback will resume from the new time. If disabled, 

playback will not resume and the system will wait for either another seek or a click on the Play 

Button – this may give the user a better sense of control over the system. Default: enabled 

Weeks start on Sunday - By default weeks are assumed to start on Monday. If the user considers 

weeks to start on Sunday they should enable this option. Default: disabled 

Overlay ms time (X200) - This option turns on the millisecond timing, per image, for X200 footage. 

The ms timestamp is shown as an offset from the timestamp of the first image in that particular XBA 

file. 

Watermark (X200) - Each image is watermarked as it is recorded, providing a guarantee of 

authenticity. As PCLink200 plays back the image, it checks the watermark to ensure that the image 

has not been tampered or altered. The water mark is then displayed in the corner of the image as a 

green W logo. A broken watermark is shown with a red line through it. The user may specify which 

corner of the image to show the watermark and also disable it being shown at all. Default: disabled 

Jog Frames – When concentrating on a single camera, the jogging system will by default jog forwards 

or backwards by a single frame. This can be altered here. A value of 5 for instance would cause the 

jog button, or ‘L’ key to jog forwards by five frames when displaying a single camera. 

OSD Text (V400/V500 and X500/R500) - When enabled (on by default) the video in PCLink has the 

time, camera number, GPS information, user defined camera text and any alarm information overlaid 

on screen. This is known as the On-Screen Display (OSD).  When disabled only the date, time, camera 

number and user defined text is displayed. By selecting an individual camera, all information is 

display on that camera only and only date, time, camera number and user defined text is displayed 

on the remaining cameras. Two options exist for Minimal display of information. These will only 

display the camera number and date/time and either at the top or bottom of the camera tile. 

OSD Speed Source – a dropdown in Options > Preferences > Speed Source gives options to use GPS 

speed or CAN speed (when available) on the OSD when playing back XBA files.  CAN speed is much 

more accurate, and can have up to 10 readings per second.  GPS tends to have just one.  

CAN speeds under 10MPH are displayed with 1 decimal place, eg 4.423 would become “4.4 MPH”. 

With speeds above 10, a leading 0 is added to identify it as a CAN speed, eg 56.2 would become “056 

MPH”. 
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GPS speeds are always rounded down, eg 15.7 becomes “15 MPH”.  CAN is rounded accurately, eg  

15.7 would become “016 MPH”. 

The “Auto” selection uses CAN if available, but reverts back to GPS if CAN is not available.  The 

leading 0 is therefore useful in making the distinction between whether CAN or GPS speed is being 

displayed.  

 

CAN speed can also be included in an MP4 export.  In MP4 exports the speed text is underneath the 

video, rather than as OSD. As with playback, you can tell if it’s CAN or GPS speed from the number 

format. (leading 0 and decimal point for CAN speeds). 

Decoder (V400/V500 and X500/R500) – Determines the hardware acceleration to be used for 

playback.  Auto is the default setting and most suitable for newer PCs/graphics cards/operating 

systems however a Legacy option may be selected if playback is not running smoothly / expected.  

Motion Skip Pre/Post - Sets the number of second PCLink will play before/after a high motion event 

is played. These settings are used with the Controls menu option Skip Low Motion Playback. 

Estimate framerates – NB this option should be used selectively, please read the following: 

The XBA file format does not store the framerates of IP cameras, so it is left to PCLink to work out 

these framerates. Often the cameras’ own video stream contains framerate information, so recent 

PCLink builds have used this by default. 

However, some older IP cameras write incorrect framerates into their video streams, and this can 

cause PCLink playback to judder and skip frames, go backwards, or generally not work well.  

The fix is to use the “Estimate Framerates” option, available in Menu > Options > Preferences or via 

the new toolbar button (see Section 3, PCLink Quick Reference Guide).  This fix doesn’t use the 

framerate information from the cameras’ stream.  Instead, PCLink estimates framerates.  However, 

this has downsides, and can result in jerky playback and/or less accurate timestamps for the first few 

seconds of a file. 
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Mapping  

If the footage you are reviewing contains GPS, PCLink can provide real-time map information. This 

live mapping relies on either an internet connection or having Microsoft Mappoint installed.  

By default PCLink will connect to the internet and use OSM Mapnik to provide on screen maps. There 

are several different map display options that can be chosen in PCLink Preferences depending on the 

type of map view is required. Any mapping data that PCLink receives is cached on the local PC hard 

disk and can be reused without re-downloading. Heavy users of this mapping feature are advised to 

delete the map cache regularly if it is using up too much disk space. The amount of local hard disk 

space used by the mapping data is calculated and displayed in MB. A shortcut to the mapping cache 

local folder is also provided. To delete the map cache, go to the Options > Preferences menu in 

PCLink and click on the Wipe button next to the Mapping Tile Cache. 

PCLink can also display a Static map by connecting to the internet. PCLink provides a single point on 

the map at the instant you press the "Open Web Map" button.  To update the location, you have to 

repeat this. There are several web map providers to choose from such as Google maps, Bing, Yahoo, 

Multimap.  

Show Map Trails – Enables / disables the map trails.  A history of the GPS route/locations can be 

toggled on/off.  Note that loading large amounts of footage with this feature enabled can cause 

playback to stutter. 

RaptorX mapping is also supported, refer to your RaptorX installation for the specific port connector 

number, this will be configured in the RaptorX client. See mapping section for further details. 

Dials  

You may choose the style of the dials and the units in which they are displayed (MPH / KPH).  
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Export 

Scale clipboard image & Scale exported bitmaps – To provide high quality video from single field 

sources, it is recorded at a resolution of 720 x 288. This means that the image pixels are effectively 

rectangular. During playback these are displayed perfectly on the screen. However, when the image 

is copied to the clipboard, it can be left in the original format or optionally scaled to the proper 

aspect ratio. The user may have a better algorithm available to stretch these images, in which case 

they should disable this option. Default: enabled 

Multiple camera export folder – Choose the default location for exporting.  Pressing the Print Screen 

button on the keyboard will automatically export all active/in view camera images to the output 

folder.  Images are named by image timing, date/time, camera number and input xba filename.  

Additionally, in the image meta data, PCLink will write the camera number to the Title tag.  This is 

useful for sorting columns in Windows Explorer (the Title column will need turning on in Windows by 

right clicking the column headings). 

General 

Cartridge autoload - When enabled, Cartridge Autoload monitors your PC’s hardware so that when a 

cartridge is attached, PCLink200 will automatically prompt you whether you want to load the files on 

it. Default: enabled 

Show diagnostic messages - Displays detailed information about errors encountered while loading 

files. Many of these are minor errors that prove confusing or unhelpful during normal use of 

PCLink200. If the user is encountering problems with recordings from a suspect unit, then it may be 

advantageous to enable this option, especially when asked to do so by the technical support team. 

Default: disabled 

Load cartridges without detailed timeline (quicker) - Enables faster loading of cartridges at the 

expense of motion data. The green bar representing available video will appear in the timeline much 

faster if this option is enabled, but the motion data will not be read until that part of the video is 

played.  

Sound Device – Select the PC playback device (some pc's / laptops may have multiple output 

devices). 

Language – Default English.  Other languages are supported with an additional translation file.  

Contact Timespace Support for further details. 

HQ Audio  

Controls the playback of the HQ Audio channels. 

Output format – can be either 16bit stereo, or 24bit mono.   Timespace recommends in general this 

should be set at 16bit stereo. The new HQ audio is stored as 24bit, but PCLink will down-sample it as 

it plays back. 



PCLink Suite 8.4.4 Instruction Manual                                                                                                      Section 4 – PCLink200 User Interface in Detail 

28 

 

Audio Gain – Due to the increased dynamic range of the new HQ Audio, the sound level can be quite 

quiet. If increased playback gain is required, amend here either with a fixed value, or by using the 

Auto Gain option.  

A fixed value is preferable since the Auto Gain option can introduce quite a bit of noise during quiet 

periods. NB this fixed value is non-linear, so it may be necessary to use a value as high as 80,000 to 

get a good result with some microphones.  When Auto Gain is enabled, pressing Copy Gain will copy 

the current gain level to the fixed gain control. This helps the user find a suitable fixed gain value. 

Audio Skew – with so much variety in video sources and playback hardware, keeping audio and video 

in sync can sometimes require additional user input. The Audio Skew setting allows the user to fine-

tune PCLink to match their hardware.  

Reset All Settings  

Resets all PCLink settings to their default values.  It is recommended to restart PCLink after clicking 

this. 

  



PCLink Suite 8.4.4 Instruction Manual                                                                                                      Section 4 – PCLink200 User Interface in Detail 

29 

 

4.2.5.3 Camera Grid Setup 

Options > Camera Grid Setup – allows the user to select the order in which cameras area displayed.  

Cameras can be set to start in a specific order, rather than the default of 1,2,3 etc.  For example a 

user may always want camera 6 to be in the first camera tile position when PCLink starts – shown 

below.   

Use the Move Up/Move Down buttons to move cameras into the desired position in the list. 

 

The default is for analogue cameras to be displayed before IP cameras, but this can be changed if 

required - select the relevant button from the right hand side.  

NB: The cameras listed cover all Timespace recording products, and therefore will not all be 

applicable to every DVR/piece of footage.  The cameras available for the currently shown footage will 

be shown across the top of the Toolbar. 

For more details on camera setup and naming, please contact Timespace.  

Individual cameras can be setup to be Rotated (image flipped top-bottom) or Flipped Horizontally 

(image reversed left-right). 

Camera order and orientation can be reset to defaults using the Reset Order button.  
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4.2.5.4 Camera audio selection 

Cameras can be given a camera a preferred audio channel.  

When the camera is selected, PCLink will try and switch to this audio channel.  

 

 

 

 

 

 

 

 

 

 

 

 

 

In the above example, cameras 1 and 2 have been assigned HQ1, and HQ2 audio channels 

respectively. With this setting any time you select Camera 2, PCLink will attempt to select the audio 

channel to HQ2. If the file has no HQ2 audio, the audio channel will remain unchanged. 

Cameras set to ‘Any’ will not change the playing audio when selected. 
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4.2.6 Help Menu 

Help menu – contains shortcuts to Open the PCLink manual, Show all manuals (display the folder in 

which all the Timespace manuals are located) and show the What's New dialog which displays the 

latest PCLink features.  

Help > Updates > Automatically Check For Updates – If ticked, on start-up PCLink will connect to the 

internet and check for updated versions of PCLink, Timespace manuals and Timespace DVR software. 

To check for updates when PCLInk200 is already running, untick and then tick Automatically Check 

for Updates. 

Help > Updates > Show Downloaded Updates – This option allows you to open the folder that 

PCLink downloads updated Timespace DVR software into. If LANLink is running on your local PC as 

well, it will use this folder to allow updates to be uploaded to units. 

Help > About PCLink - This shows the installed/registered components of PCLink.  

The Tidy Registry button removes 'self-healing' information from the registry for PCLink's various 

COM components. Normally this is not something a user should do, but in certain situations, 

Timespace Support may ask you to click it in order to help diagnose problems, or before applying a 

patch. 
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4.3 Toolbar 

 

 Load XBA file (Ctrl + O). 

 Open Load folder (Ctrl + F). 

 Load Blur – loads previously saved blur file. 

 Load Remote Unit (Ctrl + R). 

 File properties (Alt + Enter) – Displays properties for all the currently 

loaded .xba files. It also highlights the file currently playing and allows 

the user to double-click files to jump to their start times. 

 Copy frame – copy a frame from the selected camera to the  clipboard. 

 Export frame – export the selected frame as a bitmap file. 

 Export video (Shift + F12) – Export the selected region as a video file 

playable in other applications. 

 Print frames(s) (Ctrol + P) – print the selected frame(s). 

 
These four buttons toggle between Zoom to selected cameras, Priority 

Camera Mode (show selected camera larger than the others), Quad 

Camera Mode and Show All Cameras. 

  
Individual Camera Buttons – clicking on the numbered buttons displays 

that individual camera view.  Hold down CTRL to select multiple 

camera buttons. Analogue cameras are indicated by black numbers, IP 

cameras are indicated by a green numbers. 

 Show/Hide map – toggles on/off the map window within PCLink. 

 
Export the selected region as a DVD . 

 
Export the selected region as a DVD full of XBA files playable on PCs. 

 
About PCLink = provides PCLink details, date of issue, version number 

etc. 

 Check watermarks – checks the watermark in all the loaded files.  

 
Estimate framerates – may help fix playback from older IP cameras.  

See Options > Preferences for more information. 
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4.4 Information Side Panels 

The default is to show the GPS tool on the Information Side 

Panels.  Switch between the bottom tabs for the FX (effects), Blur 

tool, Bookmarks, CAN, FMS, G (G-Force), Alarms and GPS views. 

 

 

The default position for the information side panels is at the left of the screen.  

The bar positions are saved when PCLink closes.  
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The information side panels/ bars in PCLink can be resized, and the controls stretch and move 

accordingly.  They can be undocked from the main page, or can be closed completely.  

 

 

 

 

 

 

 

 

 

 

 

 

 

Click and drag the tab of the bar to detach it.   It can then be moved or merged with other bars by 

dragging and dropping into position.   Alternatively, right-click on the pane title, and select “floating”.   

Bars can also be resized individually.  

To show/hide the information side panels again, go to View > Bars and select as required.  

Alternatively, right-click in the grey area behind the video windows.  

To reinstate the information side panels to their default position, double click on the grey area at the 

top of the panel.  
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5 PCLink 200 Features and Functions 

5.1 File Password and Encryption Settings 

PCLink/PCPlayer have supported XBA file password protection for some time.   From PCLink 8.0.3 

onwards, additional password and encryption features are included. 

The information below clarifies which versions of PCLink support which file security/password 

features: 

Password-protected XBA files 

 PCLink Suite 7.4 (August 2012) and earlier – does not load password-protected XBA files (and 

gives no warning) 

 PCLink Suite 7.5 (March 2014) – loads password protected XBA files and requests password 

Encrypted XBA files 

 PCLink Suite  8.0.2 (February 2018) and earlier – does not load encrypted XBA files (and gives 

no warning) 

 PCLink Suite 8.0.3 (May 2018) – loads encrypted XBA files and requests password 

From Version 8.0.3 onwards, PCLink now also has new options to apply, change and remove 

passwords from XBA files. 

5.1.1.1 Playing back a password-protected file 

If PCLink/PCPlayer is started, and an attempt made to load a password-protected file, a password will 

be requested.  

 

If the correct password is not entered, PCLink/PCPlayer will refuse to play the file.  

Once the correct password is entered, this will be remembered by PCLink/PCPlayer, and will be used 

for all files opened in that session until PCLink/PCPlayer closes.  
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5.1.1.2 Viewing a file’s security level 

Once a file has been loaded into PCLink/PCPlayer, that file’s security level is shown in the File 

properties dialog (File->Properties) in a new Security column: 

 

Possible values are None, Protected, Encrypted. 

5.1.1.3 Setting security levels when exporting files from PCLink 

From version 8.0.3 onwards, PCLink also supports adding, changing and removing passwords from 

XBA files when exporting from PCLink. 

Towards the bottom of the File > Export Video > Export XBA file dialog is a Security dropdown. 

 

NB:   In an XBA file, only the audio and video data are encrypted.  If an incorrect password is 

entered for a password-protected file, PCLink will still open the file and show the GPS and 

accelerometer meta-data.  This is by design. 
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There are 4 options in the export security settings dropdown: 

Same As Source The exported file will use the same file security as the original file. This is the 
default. 

Not Protected The exported file will not require a password to playback. This can be used to 
remove a password from an XBA file. 

Protected The exported file will require a password to playback, but the data in the file 
won’t be encrypted. Use the field to the right of the dropdown to enter a 
new password. If you lose the password in this mode, Timespace Technology 
may be able to help you recover it. 

Encrypted The exported file will require a password to playback, and the audio and 
video data in the file will be encrypted. Use the field to the right of the 
dropdown to enter a new password. In this mode, if you lose the password, 
there is no way of recovering the footage. 

 

The “PW” edit field to the right of the drop-down is used by the Protected and Encrypted modes to 

specify a password. If the user does not enter a password and this field is left empty in those modes, 

PCLink will show a message, asking the user to enter a password. 

For any export to work, you must have entered the correct password into PCLink when opening the 

file.  If an incorrect password has been entered, the attempted export will cause an error, and PCLink 

will display an error message.  
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5.1.2 Password Management 

It is essential that users create a system for remembering passwords and the dates they were 

created and changed.   

The following should also be noted: 

 Timespace recommends a password of 5 or more characters. 

 PCLink does not store any passwords. 

 LANLink stores the last 3 passwords and will try each of these when attempting to download 

snapshots. 

 Files on the same disk may have different passwords, if the password has been changed 

during/between recordings.  When attempting to playback files in PCLink it may therefore be 

necessary to use more than one password to access multiple or older files. 

 Swapping cartridges between DVR units is not recommended, as this will present problems if 

different units have been given different passwords. 

 Adding new units to LANLink – LANLink will not automatically add passwords to new units – 

this needs to be done manually for each new unit.  Until this is done, the files on that DVR 

will not be protected.  

5.2 Blur feature 

PCLink allows the user to obscure, or blur faces or objects when exporting footage to a standard file-

format such as MP4 or AVI.  

PCLink supports many styles of blurring including various levels of Pixellation and Gaussian blurring. 

In PCLink blurring terminology, a blur object is defined as a single shape (ellipse or rectangle) that 

moves around, or resizes, as requested by the user. The blurring system allows multiple blur objects 

for each camera.  

Each camera also has an Inverted option, which allows everything apart from the blur objects to be 

blurred. This can be useful for highlighting an object/part of the image, and works particularly well 

with the ‘Darken’ blur style. 
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5.2.1 Preparing to use the blur tool 

Load the required footage (see section on loading XBA files). 

 

 

 

 

 

Select the Blur tab of the information side panel. 

5.2.2 Blur modes 

The blur system has 3 modes, which are selectable at the top of the blur panel: 

Mode Purpose 

Disabled Disables the blur system, hiding any current blurs. 

Edit Mode Used when adding or changing blur objects. All the current blur objects are 
drawn over the top of the displayed video, along with bounding rectangles. In 
this mode the blur objects can be dragged or resized directly in the video 
windows. This mode also has no buffer lag – what you see is what you’ll get. 

Preview Mode Preview mode is for previewing what the actual blur will look like in the 
exported video file. Blurring is achieved when decoding video data into 
displayable images. Since PCLink buffers decoded video to maintain playback 
smoothness, a few frames need to be played back before the preview becomes 
‘live’. Similarly when turning off preview mode, some frames may still show the 
blur effect. 

 

  

HINT: for best results, display and edit one camera at a time.  Select the relevant camera number 

on the PCLink toolbar, or double-click on the required camera image. 

Camera images should be static, i.e. footage not playing back, while blurring/editing is being 

undertaken. 
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5.2.3 Adding a new blur 

Once you have the required camera displayed, click ‘Start New Blur’. This will add an elliptical blur 

object to the camera image at the current playback time. This will also set the blur system to Edit 

Mode and select the newly added blur object.  

Your PCLink screen should now appear similar to the screenshot below: 

 

You can now move and resize the blur object to where you want it to first appear. The two tooltips 

on the new blur object describe how to do this: 

 “Drag shape to move blur” 

 “Drag handle to resize blur” 

 Dragging the object moves the object, dragging the small handle at the bottom right of the bounding 

rectangle resizes the blur object about its centre. 

 

 

 

  

HINT: The default shape for the blur object is an ellipse (“Circle”) within a bounding rectangle.  

You may use the “Shape” dropdown tab to select “Rectangle” as an alternative. 
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5.2.4 Moving a blur object to follow an object during footage playback 

For blur objects to move about you need to manually move them as the footage plays. You can do 

this in real-time, at a slower frame-rate, or by stepping forward frames. If you change the size or 

position of a blur, PCLink will remember the changed size and position and use it when it plays back. 

To keep the blur object movement smooth during playback, PCLink automatically interpolates 

size/position changes.  

As an extreme example, if you added a blur object to the left of the video at 14:50: 

 

Then at 14:51 you moved the blur object to the far right of the video:  

Between 14:50 and 14:51 the blur object would slowly move across the video: 

 

Any alterations to the blur object between these two times would obviously change the behaviour. 

When editing a blur object it’s a good idea to play the end result back in PCLink’s Edit or Preview 

modes to make sure the blur object has not moved away from your intended object. 
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5.2.4.1 In real time 

Press        to play the footage. As the footage plays, use the mouse to select and drag the blur object 

to follow the required object on the camera images.  If necessary, stop the footage and resize or 

reposition the blur object. 

5.2.4.2 At a slower frame rate 

Reduce the playback Speed, eg to x0.2.  Then follow the steps above as for real-time. 

5.2.4.3 Stepping forward, frame-by-frame 

Frame by frame adjustment may be required, eg to fine-tune coverage of a blur object.    

Use the “L” key to step one frame at a time, re-sizing and moving the blur object as necessary to 

follow the object on the image. 

5.2.5 Completing a blur object 

Once you are finished with a blur object, click ‘Stop Selected Blur’ and the blur object will hide itself. 

To show the blur object again after a period of time, just create a new blur object at the relevant 

time. 

In the blur panel there are two fields which display the start and stop times for the selected blur. 

Below these two fields is a Delete Selected Blur button. This removes the selected blur object from 

the footage, and from PCLink. 
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5.2.6 Blurring multiple objects 

Using the Start New Blur button you can add multiple blur objects to a camera.  You can also add blur 

objects, or multiple blur objects, to multiple cameras.  PCLink currently has no limit on the numbers 

of blur objects.  

Here you can see 5 blur objects, trying to hide all the cars: 

 

The currently selected blur is always shown with a white rectangle and text, whilst the other blurs 

have a grey rectangle and text. To select a different blur object, simply click anywhere within the 

bounding rectangle. You can only edit the size and position of the selected blur object. 

In preview mode, the previous example now looks like this: 
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5.2.7 Inverted blur area 

Below the Shape drop-down is the Inverted option. This inverts the area to be blurred. So for the 

above example, selecting this will blur everything apart from the cars: 

 

 

5.2.8 On-screen time display 

Note that the On-Screen time display above is still readable even when blurring is present. For most 

Timespace DVRs, the text is rendered on top of the video after the blurring, and is still visible when 

viewing blurred images. However for footage from the X200 DVR, the text display is part of the video 

image, so the blurring system will blur out the time if it’s blurring that part of the image. 

5.2.9 Blur Styles 

Towards the bottom of the blur panel is a dropdown for Blur Styles. The blurring system has a 

number of different effects which can be selected.  

 

 

 

The table on the following pages gives examples of each of the blur styles.  

  

NB: blur style is a global setting, so multiple blur objects on one camera, or blur objects on 

multiple cameras, will all use the same style. 
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Style Description  

Blank Renders the blur objects in black. 

 

Average Colour Renders the blur objects in the average colour of 
the video frame.  

 

Pixellate (Big Blocks) Pixellates the blur objects using 50 blocks across 
and 50 blocks down. 

 

Pixellate (Medium 
Blocks) 

Pixellates the blur objects using 90 blocks across 
and 90 blocks down. 

 

Pixellate (Small Blocks) Pixellates the blur objects using 150 blocks across 
and 150 blocks down. 

 

Blur A simple gaussian blur. 
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Style Description  

Artistic Blur (Slow) This applies an almost cartoon effect to the blur 
objects. This is useful if you want to blur 
something but make it less obvious that it has 
been blurred. Be warned though, it is a complex 
operation and is thus quite slow.  

Noise This blends pseudo-random values to the blur 
object.  

 

Darken This darkens the blur objects. This is a useful 
effect when the Inverted blur option is turned on. 

 

Lighten This lightens the blur objects. 

 

Edge Detection (Sobel) This applies a Sobel filter to the blur objects, 
which has the effect of highlighting edges. 

 

Edge Detection (Laplace) This applies a Laplacian edge detection filter to 
the blur objects.  
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5.2.10 Loading and Saving blur files 

In the Global Options section of the blur panel, the Load and Save buttons allow the data associated 

with blur objects to be saved and loaded back in to PCLink later on.  

To save blur data, select Save, choose your preferred file location, and name the blur file. 

To load previously-saved blur data, open the required video footage file, and open the saved blur file 

separately using the Load button.  Alternatively, use the blue “Load Blur” button on the Toolbar.  

The Clear All button completely deletes all blur objects across all cameras and resets the blurring 

system. 

 

 

 

5.2.11 Exporting blur files 

Once you are happy with your blur objects you can export a rendered version of the blur using any of 

the below menu options: 

File->Export Video->Create Video DVD 

File->Export Video->Export Video File 

File->Export Image 

File->Copy Image 

 
 
 
 
 

 

To export the blur file as an image or video, select the camera on which the blur has been created.   

To export a section of video, ensure the section markers are marking the required start and end 

points of the required piece of blur footage.  

Select File > Export Video > Export Video File 

Choose a file name and location to save the exported video and select Save. 

 

 

 

NB: the Load and Save buttons do not render blurs into video files.  See Exporting blur files for 

information on how to export a rendered video version of the blur. 

 

NB: it is important to use one of the above options rather than Export XBA file.  Exporting an XBA 

file will not export the blur, or blur data. Blurs can only currently be rendered into non-XBA files 

such as .AVI and .MP4. 
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5.3 FX (Effects) 

FX View includes; Gamma, Brightness, Contrast, Greyscale and Negative adjustments. 

Enable effects – Turns on/off the whole effects system. Use of the effects system slows playback 

down slightly therefore should remain turned off unless the effects are required.  

 

 

 

Reset to defaults – Resets all the sliders and options to their default state. 

Gamma – Adjusts the gamma level of the video. 

Brightness – Adjusts the brightness level of the video. 

Contrast – Adjusts the contrast of the video. 

Negative – Inverts the colours in the video. 

Greyscale – Removes all colour from the video. 

 

5.4 GPS and Alarms 

These tabs shows the speed based on GPS information, and the alarm indicators.    

PCLink has a graphical alarm panel that highlights alarms as they are played back in DVR footage (NB 

not supported in X200 footage). The alarm panel is displayed on the information side panel by 

selecting the GPS tab option.  

 

 

 

 

The alarm data is taken from the recorded footage using specific triggers e.g. a vehicle's LEFT / RIGHT 

indicator.  

  

NB If no alarms are present in the footage being played, the alarm panel will not be displayed. 

NB: the effects are intended for use within PCLink, and not rendered to video when exported via 

AVI, MP4, etc. 
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The triggers can be setup in the DVR using either the ALARM INPUTS configuration menu or by using 

ALARM TEXT. If the alarm type doesn’t have an icon set, the alarm text will be used to match an icon.  

The alarm types / text need to be carefully setup in the DVR to avoid being incorrectly displayed in 

PCLink during playback.  The following alarms can be configured / displayed: 

 

ALARM PANEL ICON DESCRIPTION ALARM TEXT 

on    off   

 
Ignition IGN or IGX 

 
Accelerator ACCEL, ACC or ACCELERATOR 

 
Indicator Left IND<L, INL, INDL, LH or LEFT 

 
Indicator Right IND>R, INR, INDR, RH or RIGHT 

 
Side Lights SL 

 
Head Lights HL 

 
Fog lights FL 

 
Siren SIREN or SIR 

 
Blue lights BLUES, REDS or BLU 

 
Bullhorn BULLHORN, BULL or HN2 

 
Hazard lights HAZARD, HAZ or HZRD 

 
Reverse REVERSE or REV 

 
Hand brake HANDBRK, HBK or HANDBRAKE 

 
Bridge Alert BRG or BRIDGE 
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Door (any or all) DOOR, EXIT, DR0 or DOOR0 

 
Bus Door 1 DR1, DOOR1, D01 or DO1 

 
Bus Door 2 DR2, DOOR2, D02 or DO2 

 
Bus Door 3 DR3, DOOR3, D03 or DO3 

 
Disabled Ramp RAMP or RMP 

 

  

Ctrl+Left mouse click on any of the ALARM PANEL icons will jump to the next occurrence of 

that alarm in the timeline (if any). 
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5.5 G-force 

The G-Force tabs shows Forward, Lateral, and Upwards acceleration in terms of G. 

 

 

 

G-force data can be exported in a .csv format, details are at Export Data.  

  

NB: the style of the dials and the units in which they are displayed (MPH / KPH) can be chosen in 

the Options > Preferences menu on the top line.  
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5.6 CAN and FMS 

 

  

FMS side panel CAN side panel 

 

Using the Timespace CANLink product (http://www.tspace.co.uk/timespace_canlink.asp) it is 

possible to record Engine Management (J1939 / CAN) data into XBA files. 

Timespace CANLink is available as a stand-alone unit, or a version to be used in connection with a 

Timespace DVR (the stand-alone CANLink does not produce any XBA files, so the information from 

stand-alone CANLink is not viewable in PCLink). 

PCLink has 2 sidebars which display the CAN and FMS information. 

The CAN sidebar displays all the available data in tabular form. It allows keyword searching, and 

highlights any item which matches the text in purple. CAN data itself is grouped into defined groups 

called PGNs (Parameter Group Numbers). Clicking an item in the list will highlight all other values 

from the same PGN in blue. 

Speed from CAN can be shown on the on-screen display text when playing video.  Details are here. 

CAN speed can also be included in MP4 file exports.  

  

NB: CAN data is only displayed when seen at the current playback time. When seeking via the 

timeline, the displayed CAN data is cleared so out-of-date data isn’t left in the table. Some CAN 

values may only appear once a minute, so as you play through a file, more values may appear in 

the list. 

 

 

http://www.tspace.co.uk/timespace_canlink.asp
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The FMS sidebar displays a subset of the CAN data in graphical form. The default dials for display are: 

 vehicle speed 

 engine speed 

 engine temperature 

 fuel level 

 engine load 

 accelerator pedal position.  

 

 

 

 

Below the dials are two groups of icons. The screenshot below shows what are known as TellTale 

icons.  

  

 

 

 

 

 

 

If the vehicle doesn’t supply TellTale icon information, this area is used to display engine warning 

lights and their various causes via the Diagnostic Trouble Code (DTC) system. Both systems support 

tooltip help. 

 

 

 

  

NB: vehicles may not supply all of the data potentially available on the CAN-bus.  Therefore in any 

given case, some of the dials shown above may be absent.  e.g. in the screenshot on the previous 

page, the engine load dial is missing. 
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With both TellTale and DTC icons, a blue icon indicates ‘information’, an amber icon indicates a 

warning, and a red icon indicates something serious. In the screenshot on the previous page, two 

amber warnings are shown for lamps.  Below the TellTale/DTC icons are more general icons which 

come from CAN’s flag data. Included here are things like door status, current gear, and brake status. 

 

 

 

Finally at the bottom is a section containing textual numeric data for things such as total distance, 

fuel used, fuel economy, etc. 

 

 

 

Blank items in the FMS tab indicate that the CAN data didn’t contain any information about them.  
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5.7 PTZ controls 

PCLink Suite V7.2 onwards includes the ability to control any PTZ cameras that are configured and 

connect to the Timespace X300 Digital Video Recorder (see X300 Product Manual for X300 PTZ 

configuration). 

The main PTZ functions are to move the camera Left, Right, Up, Down, Zoom in and Zoom out.  

Advanced features include setting up focus behaviour and accessing the cameras internal menus (if 

the camera supports it - see cameras manufacturer user guide for details).  

8 user defined camera positions (Presets) can be setup. For example preset position 1 could be a 

scene view overlooking a car park, preset position 2 could be zoomed in close to the entrance, preset 

position 3 could be pointed at the exit. The presets can be quickly accessed by pressing the number 

keys on the PCLink PTZ control bar. It may be necessary to click and hold for some camera types. 

 

Once a PTZ camera has been configured and connected to the X300, a remote IP connection can be 

used to connect via PCLink and view/control the camera. Any configured PTZ cameras will show up in 

PCLink with an additional control bar under the camera window. 
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5.7.1 PTZ control bar 

 

 

 

 

 

 

 

PTZ control bar - button functions - In addition to the above button controls, there are some 

advanced PTZ features that can be accessed by holding the CTRL or SHIFT button on the keyboard, 

then pressing the buttons. Below is a table of all the button functions. 
 

Button Normal Left click CTRL + Left mouse click Shift + Left mouse click 

1 GOTO PRESET 1 SET PRESET 1 CLEAR PRESET 1 

2 GOTO PRESET 2 SET PRESET 2 CLEAR PRESET 2 

3 GOTO PRESET 3 SET PRESET 3 CLEAR PRESET 3 

4 GOTO PRESET 4 SET PRESET 4 CLEAR PRESET 4 

5 GOTO PRESET 5 SET PRESET 5 CLEAR PRESET 5 

6 GOTO PRESET 6 SET PRESET 6 CLEAR PRESET 6 

7 GOTO PRESET 7 SET PRESET 7 CLEAR PRESET 7 

8 GOTO PRESET 8 SET PRESET 8 CLEAR PRESET 8 

< PTZ LEFT IRIS RESET IRIS RESET 

> PTZ RIGHT PTZ FOCUS AUTO PTZ FOCUS MANUAL 

^ PTZ UP 
  

v PTZ DOWN 
  

- PTZ OUT PTZ FOCUS FAR PTZ IRIS CLOSE 

+ PTZ IN PTZ FOCUS NEAR PTZ IRIS OPEN 
 

NB – not all PTZ cameras will support all of the above advanced features. See camera manufacturer’s 

documentation for further details. 

  

User defined Preset positions. 

Once the camera is in the desired position, 

hold the ctrl key on the keyboard, then 

select the number to preset that position. 

Hold shift + the number to unset. 

 

Click to recall to the preset positions. 

Zoom out 

Zoom 

In 

Left, Right, Up, Down Access camera’s 

internal menu 

system (if 

supported by 

camera).  
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5.8 Mapping 

PCLink supports two methods of mapping; real-time and static. Both methods are reliant upon GPS 

data within the Timespace XBA file format. GPS data is embedded into the XBA file during recording. 

PCLink will read this GPS data and can either display a real-time map or a link to a static map on the 

internet. 

NB:  GPS location data can be exported as standard GPX files.  See Export Data for further details.  

 

 

5.8.1 Real-time mapping 

PCLink V7.3 onwards has a built in, real-time mapping feature based on OSM Mapnik. PCLink will 

read the GPS data in a loaded XBA file and display a real-time map in line with the GPS data.  

Real-time mapping is also supported when connecting remotely via IP to an X300, X500, R500, V400 

or V500 DVR. If the DVR has a GPS feed, PCLink will load the map location along with the Live video 

data stream. 

An internet connection is required in order for the maps to update in real-time. Any mapping data 

that PCLink receives is cached on the local PC hard disk and can be reused without re-downloading, if 

the same footage or footage with the same location is played back. Heavy users of this mapping 

feature are advised to delete the map cache regularly if it is using up too much disk space. Within the 

PCLink options, the tile (map) cache size in MB is calculated and displayed. 
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There are several real-time mapping feeds and display types that can be selected depending on the 

users preference. These can be selected using the Mapping Playback pulldown menu within PCLink 

preferences;  

  

 

PCLink can also use Microsoft Mappoint (if installed) for real-time mapping. Current supported 

versions are 2006 Europe and 2006 North America (later versions should work also). These are 

separate applications that must be licensed and sourced aside of PCLink Suite.  

RaptorX mapping is also supported and PCLink serves GPS data to a RaptorX client. RaptorX is a 3rd 

party mapping application used by the American military. Textual GPS RMC lines are sent via a 

configurable software socket (default is 7017) which the RaptorX client will receive.  

NB: To delete the map cache, go to the Options > Preferences menu in PCLink and click on the 

Wipe button next to the Mapping Tile Cache; 
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5.8.2 Static mapping 

An Open Web Map button is provided on the GPS dial side panel. If the footage you are reviewing 

contains GPS data, PCLink will connect to the internet and provide you a single point on the map at 

the instant you press the button.  To update the location, you have to repeat this step.  

Within the Options > Preferences dialog, there are several web map providers to choose from. You 

may also choose the style of the dials and the units in which they are displayed (MPH / KPH) and 

after which camera the map tile will appear.  
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5.8.3 Map trail 

PCLink will display a route history based on GPS data loaded with XBA file(s).  The arrows below the 

map image can be used to re-centre and zoom the map in or out. 

 

 

 

 

 

 

5.8.4 Bookmarks 

PCLink has a “bookmarks” feature in mapping, where users can mark points for later reference.  

Enabling this feature requires telnet command set-up by the user; contact Timespace for further 

details on 01480 414147 or support@tspace.co.uk ). 

  

NB: loading large amounts of footage with the map trail feature enabled can cause playback to 

stutter.  See Real-time Mapping section for how to delete the map cache.   

 

mailto:support@tspace.co.uk
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5.9 Undock camera / map tiles 

PCLink can undock any of the camera or map tiles from the main PCLink windows into its own 

window. The undocked window can then be move and resized according to the users preference.  

A tile can be undocked by selecting it (tile border highlights red) then clicking the View menu and 

selecting Undock Selected. The map can also be undocked this way or by using its own Undock Map 

menu link.  

This feature is particularly useful when playing back footage on duel screens e.g. a camera tile could 

be placed on a second screen and run in full screen next to the other video footage; 

 

 

Each undocked window has its own controls for Minimise, Maximise and Close. If the Close control is 

clicked, the tile will re-dock into PCLink. To re-dock all undocked tiles, use the menu link View > 

Redock All.  

  



PCLink Suite 8.4.4 Instruction Manual                                                                                                      Section 5– PCLink200 Features And Functions 

62 

 

Screenshot of multiple undocked tiles; 

 

 

5.10 Camera Zooming 

Multiple cameras can be zoomed at different levels during playback by using the mouse scroll wheel. 

Once zoomed in, the image can be panned by clicking & dragging. 

 

Original image: Zoomed section: 
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5.11 Motion Detection – X300/X500 Remote setup 

The X300 motion detection mask can be setup whilst remotely connected in PCLink; 

1. Select the camera you wish to setup. 

2. Click the MASK button in the bottom right hand corner of the camera tile. 

3. A grid will overlay the camera view and by default display a large GREEN area. Any areas 

shown in GREEN are areas that will be monitored for motion. 

 

4. If you are happy with the default area, click the SET button*. This sends the grid 

include/exclude area information to the X300 (similar to if it was set locally using the 

Reviewer). 

5. Next click the MENU button and navigate through the menu system to MOTION DETECTION 

and setup the sensitivity and which mode of recording motion detection should trigger. 

 

* If you do not want to use the default GREEN area, you can edit the mask by clicking and dragging 

with the mouse. If an area is GREEN, clicking and dragging on it will highlight the area RED and 

EXCLUDE it from being monitored for motion. Once the mouse button is released, the red area will 

disappear. Click the SET button to send the grid to the X300. 
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If an area is GREEN, clicking and dragging it will turn it RED whilst dragging, then no colour. 

If an area is RED, clicking and dragging it will turn it YELLOW whilst dragging, then turn GREEN. 

If an area has no colour, clicking and dragging it will turn it YELLOW whilst dragging, then turn 

GREEN. 

 

Multiple areas of any size can be setup. 

 

NB Remember to click the SET button once you are happy with your selection(s)!  
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5.12 Exporting 

There are several methods for gathering footage of an incident or for providing footage to another 

party. 

 

1. With the DVR Cartridge plugged into a PC via the USB cable, simply select the files you 

require from the Drive letter assigned to the cartridge, using Windows Explorer. Copy them 

to a local folder / network drive and then burn to CD/DVD as required.  

 

2. Export footage in Timespace XBA format (File > Export Video > Export XBA File). This is more 

precise than method 1 as it allows you to export an exact clip from a start/end date & time.  

 

3. Export footage/audio to a standard file using a codec installed on the PC (File > Export Video 

> Export Video File / Export Audio File).  

 

PCLink can export video / audio to the following formats; 

 

 AVI  – All Timespace DVRs 

 WAV  – All Timespace DVRs 

 MP3  – All Timespace DVRs other than X100 and X200 

 MKV  – All Timespace DVRs 

 MPG   – All Timespace DVRs 

 MP4   – All Timespace DVRs       Recommended 

NB:  MP3 / WAV are audio-only files and will not contain any video images. 

 

4. Export directly to DVD - two options exist for this method;  

 (a) convert XBA data to a DVD Player compatible format and burn 

 (b) burn XBA as a data DVD and include PCPlayer     Recommended 

 

NB Method 2 or 4 (b) are recommended as it maintains all the original file data including multi 

cameras, audio, watermarks and additional data such as GPS, GSensor.   
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5.12.1 Export Video 

PCLink provides a number of options for video export via File > Export Video. 

5.12.1.1 Export XBA file 

File > Export XBA – Exports the section of footage between the start and end markers as an XBA file.  

A dialogue box will appear allowing the user to select which cameras, audio channels and data (GPS 

and motion) is included in the exported XBA.  

 

 

The maximum file size can be limited in order to fit the resultant parts to certain media e.g. CD/DVD.  

In this case if the total size of the exported footage exceeds the maximum file size selected then a 

number of files will be created all with the same name as entered in the ‘File Name’ box, but having a 

suffix to the file name -part2, -part3 etc. The user can select one of the standard maximum file size 

limits or alternatively select ‘Custom’ from the drop down menu.  If custom is selected then the user 

inputs the required maximum file size in the ‘Mb’ window next to the drop down menu. 

Exporting GPS – GPS tracks can be exported as standard GPX files.   A GPX file is a GPS data file saved 

in the GPS Exchange format, which is an open standard that can be freely used by GPS programs. It 

contains lists of longitude and latitude location data that make up the tracks PCLink displays on the 

map. Information such as speed and bearing is also included, but the files contain no video data, so 

are quite small. 

Export to GPX is done by changing the ‘Save as type’ in the dialogue box in the File > Export Video > 

Export XBA file dropdown. 
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5.12.1.2 Export video file 

There are several options for exporting video files:   

 export individual cameras 

 export all cameras at once as separate (multiple) files  

 export all cameras at once as streams in the same file 

 grid export – export a single-stream MP4 file which contains multiple cameras arranged in a 

grid (similar to the DVD export option).   

These options are accessed via File > Export Video > Export Video Grid or Export Video File.  Users 

can select to save video as *.mp4, *.mkv,*.mpg or *.avi files. .  

 

 

 

VLC Media Player – VLC has a long-standing issue when playing video with very slow frame rates.  

PCLink therefore offers a frame-doubling option for low IPS cameras to increase compatibility with 

VLC. 

NB:  the default is that all available cameras are selected, along with “Multiple Files” and “VLC 

Playback Compatibility”.  

For Export Video File and Export Grid, users have the option of selecting the video quality (and 

framerate for Export Video Grid). 
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Timespace recommends that the original image quality and framerate are maintained if possible.   

However, if a reduced file size is required, the image quality and framerate can be reduced. 

Include Audio – the default setting is to include Audio in the export.  Users can select the Audio 

bitrate and which audio channels to include.  The default setting is Standard audio channels. This is 

generally suitable in most cases, however if reduced file sizes are required, the bitrate can be 

reduced.  

NB:  the  HQ (high-quality) audio channels refer only to the High-Quality audio from 

Timespace X500 DVRs. 

Audio can also be exported separately via File > Export Audio  

Filter Odd Fields - For interlaced D1 footage recorded by the X300 connected to a multi-field camera 

the video stream will contain both odd and even fields. When exporting an AVI, depending on the 

codec used, it may be preferable to just export one of the two fields. 

 

 

 

 

 

 

 

Note:  Exporting to AVI – If exporting to AVI, bear in mind that the maximum supported file size for is 

2GB, if this is reached the AVI export will abort with an error message shown. It is therefore advised 

that a compression codec is used. The XviD codec gives the best quality/file size for .AVI output. 

For XBA files recorded using the Timespace X200, PCLink supports exporting the Watermark with AVI. 

The AVI export dialog has an “Include Watermark” checkbox. When ticked, the frames in the 

exported AVI file will have the PCLink Watermarking symbol burned into them: 

 If a frame passes the watermark test, it gets a green ‘W’ symbol 

If a frame fails the watermark test, it gets a green ‘W’ symbol with a red line through it. 

The symbol’s position is the same as in PCLink, and can be changed via the options. The checkbox is 

only visible for X200 footage on the export dialog above, in place of the Filter Odd Fields. 

  

NB: Although MPG / MP4 / MKV can export all cameras into files as separate streams, many video 

players will not play back these extra streams, so this is not recommended.   

Multiple cameras can be output to separate files using the “Multiple Files” option, which is ticked 

by default. 

Alternatively, Grid Export is the recommended means of sharing footage with multiple cameras 

on view (File > Export Video > Export Video Grid). 
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5.12.1.3 Create XBA DVD 

The following steps describe how to export a clip of footage from an xba file(s) and create a DVD.  

This is the recommended method of archiving and providing footage to a third party.  It is also the 

quickest method with the best quality and maintains the original recorded files. 

 

STEP 1 - Move the yellow markers in the timeline to the start & end points of the footage required. 

 

 

 

 

 

STEP 2 - Click the Export XBA DVD button on the toolbar (choose the filename and location of the 

output file), the click Save. 

continue overleaf .... 

  

End marker Start marker 
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STEP 3 - Click Burn; 

 

 

 

NB - The .iso file created in step 2 could be burned again if multiple copies are required.  This output 

file required manual deletion once the user has finished burning DVDs. 

5.12.1.4 Create Video DVD 

Similar to the Export XBA DVD method, video data can be exported from PCLink directly to a DVD, 

converting at the same time to a format that can be played on a standard DVD player.  Converting 

XBA to DVD does take some time however it can be useful for playing back footage where a PC isn't 

available. 

 

For best results it is recommended to only export continuous clips of footage, less than 30 minutes in 

length.  Exporting mixed camera rate footage may produce unstable results.  If this is experienced it 

is recommended to Export Video as MPG4 then produce a DVD using a third party program.  Multi-

camera and/or X200 exports will be quite slow.  All export times are dependent on the PC processor 

speed, newer multi-core or i3/i5/i7 processors are recommended. 

 

Video and audio data can be exported to DVD however mapping information is not included.  The 

export folder may leave behind a temporary folder and/or some files.  Temporary files/folders should 

be removed automatically by PCLink else they should be manually by the user after the DVD has 

been burned.  As with Exporting XBA to DVD the .iso output file could be used to burn multiple 

copies.  Again the user should remove this manually afterwards. 
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During the export, each selected camera channel is converted then all cameras are combined in to a 

DVD format for playing back in Windows Media Player (or equivalent player) OR on a DVD player; 

 

 

 

 

5.12.2 Export image 

Exports the currently selected camera view as a Windows Bitmap or JPEG to a location specified by 

the user. JPEG produces file sizes approximately 20 times smaller than bitmap with no discernible 

loss in image quality. 
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5.12.3 Export Audio 

Exports the section of footage between the start and end markers as a WAV or MP3 file.   

 

 

Choose the output file name/destination and the period of footage required.  

The default setting is Standard audio channels. This is generally suitable in most cases, however if 

reduced file sizes are required, the bitrate can be reduced.  

NB:  the  HQ (high-quality) audio channels refer only to the High-Quality audio from Timespace X500 

DVRs. 

5.12.4 Export Data 

PCLink can export mapping, GPS speed, GSensor and Motion Data.  See Export Data for details.   
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5.13 V700 support 

PCLink V8.4.2 is the first version which will connect to Timespace V700 network video recorders.   

When connecting to a V700, wait for the unit to have been pinged in the Load Remote Unit dialog 

box before opening the unit.  This is because the ping reply tells PCLink which cameras are available.  
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6 File Transfer 

6.1 X200 File Transfer:   X-Communicate 

The X200 Digital Video Recorder incorporates a TFTP (trivial file transfer protocol) server which 

allows the stored video files to be downloaded using either a hard-wired, or wireless, network 

connection.  The files can be accessed and downloaded using any TFTP client application. 

 

X-Communicate is a simple TFTP client application which allows the listing and transfer of files from 

the X200.  The screenshot below shows how the application appears during file download. 

 

 

 

6.1.1 Download 

To download a file from an X200 follow the steps below: 

1. Start the X-Communicate application. 

2. Enter the X200 IP address in the host IP address field. 

3. Click Connect; wait until communication has been established (files displayed). 

4. Select the required file, scroll through the pages if necessary. 

5. From the menu, select File and then Download or double click the file. 

6. Select a local name for the transferred file. 

7. As the file is transferred the flashing down arrow indicates transfer activity, there is also a 

progress bar and a percentage complete figure. 
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6.1.2 Menus 

The menus allow the user to configure and control the X-Communicate application.   

File > Download - This menu selection is enabled when a file has been highlighted in the File Listing 

Area. When selected, a dialogue is displayed which prompts the user to select the name of the file to 

be used locally.  By default, the same filename as on the X200 is displayed. 

File > Exit - Selecting this option closes the X-Communicate application. 

Options > Multiple Acknowledgments - File download from the X200 using TFTP is accomplished by 

the transfer of a number of blocks, each of which is acknowledged before the next is sent.  To speed 

up transfer, the protocol permits a number of blocks to be in transit which have not been explicitly 

acknowledged.  This approach can improve transfer rates. 

Options > 1024byte Blocks - The X200 implementation of the file transfer protocol supports different 

size blocks.  If this option is selected then blocks of 1024 bytes will be transferred; if it is deselected 

then the files will be transferred in blocks of 512 bytes.  In general, the larger block size will incur less 

overhead if the transfer of data is reliable and so will give better transfer rates; hence, this is the 

default. 

View > Small Icons  - Selecting this option displays the files on the X200 as small icons. 

View > Icons   - Selecting this option displays the files on the X200 as large icons. 

View > List   - Selecting this option displays the files on the X200 as a list. 

View > Details   - Changes the display of the list listing as per user preference. 

View > Refresh  - Update file listing or re-establish connection with an X200. 

Help > About   - Displays a dialogue with the software version number. 

6.1.3 X-Communicate Window 

File Listing Area - The file listing area displays the files stored on the remote X200 that are available 

for download. Where more files are available than can be displayed in the file listing area, the vertical 

scrollbar to the right can be used to move between pages. 

File Indicator - This field shows the number of files available for download on the remote X200 

specified by the entered IP address. 

Page Indicator - This field shows the current and total page numbers. Use the vertical scrollbar to the 

right of the File Listing Area to move between pages. 

Host IP Address - Each device connected to a network must be configured with a unique IP address.  

Enter the IP address of the X200 you wish to connect to in order to download video files.  
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Status Line - Displays any status messages should the X-Communicate application be unable to 

connect to the specified X200 and also the transfer rate and time remaining during file download. 

Transfer Progress - A progress bar and a percentage indicator update as a file is downloaded. 

Cancel Button - During file transfer, the download can be aborted at any point by selecting the cancel 

button. 
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6.1.4 Remote Access: RemoteLink 

RemoteLink is a PC facsimile of the hand-held X201 Reviewer which allows the user to connect to a 

remote X200 unit via serial (RS232), LAN and GSM modem interfaces  (including UMTS, EDGE, 3G, 

GPRS and GSM wireless routers), and control it as if using an X201 Reviewer.  

 

All features of the X201 Reviewer are supported except Motion Detection edit/view Mask. Menus 

can be accessed and modified, live video and recorded footage viewed. Note that via GSM the X200 

video switcher dwell times will be multiplied by 10 in order to take into account the inherent time 

delay in the GSM connection. 

  

The user can connect to any number of X200s in turn allowing checks and menu changes to be done 

when recorders are in operation and not currently accessible to an operator equipped with a 

Reviewer. The X200 can be contacted whenever it is powered and wherever a connection is 

available.   
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6.1.4.1 Connecting 

 

1. Go to the File menu and select Connect To Unit 

2. Add a new unit using an IP Address, Phone number or Com port. 

3. Highlight the unit you wish to connect to and click the Connect button (alternatively you can 

double click the unit. 

 

NB RemoteLink V1.7.8 (PCLink Suite V7.2) onwards supports IP ports as part of the IP address e.g. 

10.0.0.200:1234. This is particularly useful where multiple DVRs are behind a router/firewall. 

 

 

 

The units can be ordered by each of the column headings, Name, Number or Type. The last unit 

connected to will be highlighted. 
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The Options button will open a dialog for you to select which modem you wish to use (if connecting 

via dial-up/GSM). This list is populated from the operating system, Windows. You can add new 

modems through Windows control panel. 

 

 

 

A character set option is included for switching between eastern and western European character 

sets (used in conjunction with an X200 language file). 

6.1.4.2 Controls 

If the user is familiar with setting up the X200 using an X201 Reviewer there is little further to learn - 

you have the same functionality but remotely.  The software allows the PC to remotely connect to an 

X200 unit and once the connection is made the control is as the Reviewer. 

 

 Arrow keys can be used to navigate the menu system. 

 Esc key mimics the Exit button on the review/RemoteLink.  

 Number keys 0-9 can be used to select cameras and input data.  

 F1 is used for displaying help and switching to cameras 9-16 (T516 only).  

 R = record 

 K = play 

 J = reverse play 

 L = fast forward 

 H = rewind 

 Space = Stop/Jog 

 F5 = refresh 

It is important to bear in mind that when using GSM the data rate is 920 bytes per second (a typical 

full image is 50,000 bytes) so playing back images, or displaying a live view takes time. 

 



PCLink Suite 8.4.4  Instruction Manual                                                                                                                                            Section 6 – File Transfer 

80 

 

For a direct serial connection the X200 serial connector on the rear of the recorder will need to be 

connected to an available serial port on the PC. 

Please note that as the GSM modem and GPS receiver (if used) require the use of the serial port on 

the rear of the X200, neither of these devices can be used whilst a direct serial connection is made to 

a PC. 

RemoteLink uses UDP port 5465.  Any installed network or local PC firewalls may have to be 

instructed to allow the use of this port to prevent communication problems between the PC and 

the X200. 

 

6.2  File Transfer  

6.2.1 FTP 

All Timespace DVRs/NVRs except the X100 and X200 support FTP over TCP/IP using the Ethernet 

(LAN) socket. The DVRs' FTP servers allow video files to be downloaded using either a hard-wired, 

wireless or 3/4G IP connection. When using FTP over 3/4G or in a strict network environment, 

ACTIVE mode FTP must be set in your FTP client. A web browser can be used to FTP onto the DVR by 

typing the following in the address bar;  

 

ftp://user01@10.0.0.200/ (default IP). This will prompt for the password. 

ftp://user01:PASS01@10.0.0.200/ (default IP). This will log straight in. 

 

Supported browsers are: Microsoft Internet Explorer & Mozilla FireFox. A third party FTP client can 

also be used, for example FileZilla. Once connected, files can be downloaded, viewed and deleted 

(client dependent). If prompted, the FTP authentication details are; 

Username: user01 

Password:  PASS01 

 

ftp://tspace01@10.0.0.200/
ftp://tspace01:TS01480@10.0.0.200/
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If connected to a DVR remotely using the Live, Playback, Configuration features, selecting File > 

Properties (Alt+Enter) will open a file listing to the X300 cartridge. Clicking the Open Folder button 

will automatically log in to the DVR, opening a browser FTP window. 

6.2.2 Remote Control: TELNET 

The X300, X500, R500, V400 V500 and V600 have a comprehensive set of RS232 control commands 

that run over the Serial port. This open architecture allows integration with third party 

hardware/software. In addition to the RS232 support, the X300/X500/R500/V400 provide a Telnet 

interface over TCP/IP. The same command set detailed in the RS232 section can be used over 

Ethernet using the Telnet protocol. Please refer to the DVR manuals available here; 

www.tspace.co.uk. 

 

  

http://www.tspace.co.uk/
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Here is a simple connectivity test between PC and a DVR using a Telnet client (e.g. Putty, Termite); 

 Telnet (port 23) to 10.0.0.200 (default X300 IP) 

 Enter the username & password (as above) 

 Type #HANDSHAKE; you should receive OK. 

 An example of some other commands are; #RECSTART & #RECSTOP 

 Type quit to exit. 

 

6.2.3 Remote Access:  Load Remote Unit 

With higher connection speeds over IP, Timespace DVRs support live view of cameras, playback of 

recorded files and menu configuration through the PCLink application. All functions can be 

performed whilst the DVR is recording. Note that passwords set on the DVR are not currently 

supported remotely. Remote access is currently for single user access only. 

From the File menu, select Load Remote Unit. In the dialog box, enter the IP address and a friendly 

name for the DVR you wish to connect to, then click the Add button. The unit will appear in the 

saved list and PCLink will try and test connectivity using ping. If basic connectivity is established, 

PCLink will display the remote Unit Type, unit serial number and software version.  
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After adding a unit, advanced options can be changed by highlighting the unit and clicking the Edit 

button: 

When Connected Show – select from options of 

either Live view (all cameras or a single camera), 

Playback, or displaying the DVR Menu.  NB This is 

currently the only way of connecting to V700  

menus remotely. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Telnet and FTP connection username/passwords 

can be edited here to align with those set on the 

DVR (relevant DVRs only). 

Adaptor IP – Select which network adaptor to 

connect with. It may be necessary to specify this 

when multiple adaptors exist on the PC. 

Remote Ports - PCLink uses UDP port 7 and TCP 

port 2055 for connections. 

Bandwith Options  

Dynamic Live quality allows adjustment of the 

quality of the live video.  This is useful when 

connecting to units on slow mobile connections.  

NB:  not all DVRs support the dynamic quality.. 

Reduced Live framerate reduces the framerate 

of the live video to 2IPS. 

If both Reduced Live quality and Reduced Live 

framerate are selected, the quality drops still 

further. 

Request Live Meta toggles the sending of live 

meta packets – this is required in order to use 

live GPS or alarms features. The overhead having 

this on is not very high. Not all DVR builds 

support this, so it may still send the packets even 

if being told not to. 

Selecting Request Playback Meta will instruct 

PCLink to request all the meta data from a 

remote file when it starts playing it. The 

overhead for this is quite high, so it’s worth 

turning off if you don’t mind not seeing alarms or 

GPS for the file. 

Request File List should be turned on if playback 

from remote files on the DVR unit is required. If 

only Live View is required, it is sensible to turn 

off Request File List in order to save time when 

connecting. 
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6.2.4 Live view 

To connect, either double click the unit in the list or highlight it and select Open. By default, once the 

connection is established, Live View will be displayed for all cameras. The Live button on the control 

bar will be highlighted; 

 

 

 

6.2.5 Multi channel live view 

All connected cameras can be viewed Live, simultaneously. As with Playback, cameras can be 

displayed in Show All Cameras, Zoom to Selected Camera or Priority Camera Mode. 
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6.2.6 Remote Playback 

The DVR supports playback of recorded video files remotely; note that audio playback is not 

currently supported. Selecting the Play control button will by default set the play position to the first 

file on the DVR. Move the play head position along the timeline to the required date/time.  

 

 

 

When in playback mode, only a single camera can be viewed at once and the currently recording file 

cannot be accessed. By default all cameras will be displayed but only one will show video footage. 

Select the camera channel you wish to view by double clicking it; 

 

         

 

NB playing back footage remotely is not the same as viewing locally on a cartridge connected via 

USB. The play controls can be used as normal although greater than 1x speed is not possible due to 

bandwidth limitations. The footage is streamed directly from the recorder and is not stored locally on 

the host PC. 

 

 

 



PCLink Suite 8.4.4  Instruction Manual                                                                                                                                            Section 6 – File Transfer 

86 

 

6.2.7 Remote Configuration 

The DVRs (later than X200) support menu configuration changes Remotely. Selecting the Menu 

control button will display the DVR menu system.  

 

 

 

The menu system can be configured in the same way as if using the Timespace Reviewer (X201 or 

X301) locally. 

NB the only way to connect to V700 menus remotely is to set this as the option in the Unit 

Connection Settings. 
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To navigate the menu system use the arrow keys on your PC’s keyboard. This will move the on screen 

arrow cursor between menu items.  

 

 Move arrow cursor to the previous item. 

 

 Move arrow cursor to the next item. 

 

 If the arrow cursor is currently at a menu selection pressing the left button will cycle 

the value backwards 

 

 If the arrow cursor is currently at a menu selection pressing the right button will cycle 

the value forwards 

 

 If the arrow cursor is currently at a sub-menu title pressing the right button will enter 

this sub-menu. 

 

The MENU EXIT (escape/backspace) will exit the current menu and move back up one level in the 

menu system when. If already at the top level of the menu pressing this key will exit the menu 

system completely and return to Live View.  
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A navigation dialog is shown each time the Menu control button is pressed, with the option to turn 

off future displays. 

 

 

 

Menu navigation can also be performed using the PCLink tool bar icons. Use the PC keyboard number 

keys to select cameras or use the toolbar icons. The 9/16 icon mimics the Timespace Reviewer’s 

9/16/HELP button. This will provide X300 on screen help for the current menu item feature. 

 

 

The record status is shown on the Control button section and can be toggled on/off remotely. 

Recording can continue during all Remote features; Live View, Playback, Configuration. 

 

 

To disconnect from a DVR, use the Disconnect Unit button on the toolbar or select disconnect unit 

from the File menu.     
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If the remote unit is disconnected, a Reconnect button will appear in the bottom left to re-establish 

the connection to the last connected unit.     

 

The quality of the Live images can be adjusted to cater for available bandwidth / preference. Use the 

Live Quality slider to select between Low, Med, High and Super quality. The slider only appears when 

remotely connected to a DVR. The slider position is saved as a user preference, based on its last 

position. 

 

 

6.2.8 Network Ports / Port Forwarding 

In order to communicate with the DVR network interface where a router or firewall is in place, 

certain network ports must be opened up to establish the connection and transfer data.  

 

ICMP pings must be forwarded through the router to the DVR. 
 
In addition, PCLink likes access to: 
 www.tspace.co.uk (port 80) to get XOS/news/manual updates. 

  

http://www.tspace.co.uk/
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Consult the manufacturer’s documentation for the router / firewall in order to configure the device 

to allow the above ports through to the internal IP address of the DVR.  PCLink and the DVR support a 

single level of Network Address Translation (NAT) only.  

In some instances Microsoft Windows firewall may also need to be configured to allow the above 

ports through. This may also be the case with other third party security applications. 

 

Load Remote Unit Port Support 

Multiple DVRs can be used behind one router/firewall by editing the connection from the Load 

Remote Unit dialog box;  

 

 

Custom ports can be entered instead of the defaults shown above. These must then be port 

forwarded in whichever firewall/router controls the network to the desired DVR.
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7 Software Updates And News 

PCLink now has a Caption Bar which houses 3 buttons.  The buttons go yellow when there is new 

information for the user. 

 

Latest News – Occasionally Timespace will share some news regarding software or product releases, 

displayed by clicking on the Latest News link in the caption bar.  

 

 

 

 

 

 

 

 

 

Software updates – If new software (XOS files for Timespace DVRs or PCLink updates) or manuals (in 

PDF form) are available, the New Software Available button is highlighted in yellow, and shows an 

exclamation badge. 

Clicking it shows the Updates Available dialog, which also allows the user to register a name, 

company and email address.  

Updated DVR Instruction Manuals will also be shown if available.  
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Some basic user information will be collected and the option to be included in future software and 

product notifications. 

Help > Updates – users can ask PCLink to Automatically Check for Updates and to Show 

Downloaded Updates.    PCLink will automatically connect to the internet and check for updates for 

PCLink and Timespace DVR software periodically. If this is being run for the first time, updates will be 

found and downloaded. Subsequent checks where no new version are available, the download will 

be skipped.  

 

 

NB:  from PCLink V8.4.2 onwards, old XOS files, PDFs and PCLink versions will be removed when new 

latest versions are downloaded.  

This “cleaning” only happens when a new file is downloaded.  Only files of the same type, and for the 

same DVR, are cleaned.  

What’s New in PCLink – this displays information about PCLink software updates and new/improved 

features. 
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Show Downloaded Updates...   PCLink will open the local folder that the updates were downloaded 

to.  

 

 

 

If updates are available for Timespace DVRs, the downloaded .xos files will be stored in the DVR sub 

folder e.g.  Update\X200\X200 V2.0.1.xos. See DVR product manual for instructions on loading a .xos 

file to the DVR. 

If a PCLink Suite update is available it will be downloaded as a .zip file using the PCs Internet browser, 

giving the user the opportunity to Save the file to their preferred folder. Once complete, the file must 

be unzipped to a temporary folder and TSSplash.exe run (double clicked). This will initiate the PCLink 

installer. 

 

 

 

 

FINAL PAGE
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Appendix – Manual revision history 

Issue 9, 29th May 2025 

  

 

 

  

  

  

  

  

  

  

 


